Webmaster Forum

Go Back   Webmaster Forum > Web Development > Coding Forum

Coding Forum Problems with your code? Discuss coding issues, including JavaScript, PHP & MySQL, HTML & CSS, Flash & ActionScript, and more.


Reply
 
Thread Tools Display Modes
Share |
  #1  
Old 09-01-2010, 03:52 PM
Rhyfelwr Rhyfelwr is offline
Contributing Member
 
Join Date: 08-21-10
Location: UK, Midlands
Posts: 79
iTrader: 0 / 0%
HTML markup problem

Hi all

When trying to validate my site, I am getting errors and warnings relating to the dynamically generated links - specifically with multiple URL parameters.

http://validator.w3.org/check?uri=ww...Inline&group=0

I have looked through the problem which is to do with the "&" and "=" symbols... which are needed???? This isn't meant to be a &amp symbol!

Confused and hoping someone can help.

Page is www.qualityimagesearch.com/index.php
 
Reply With Quote

Advertisement

Advertisement

  #2  
Old 09-01-2010, 05:14 PM
Luxmo's Avatar
Luxmo Luxmo is offline
Member
 
Join Date: 07-08-10
Location: City of Industry, California
Posts: 36
iTrader: 0 / 0%
Since you chose to use XHTML your document needs to conform to XML laws.

When printing to the document ASCII and other special characters, you need to print them as their entities.

PHP Code:
$your_link 'http://www.yourdomain.com/mypage.php?this=this&that=that';
echo 
'<a href="'.htmlentities($your_link).'">The Link</a>'
The above code will print:
Code:
<a href="http://www.yourdomain.com/mypage.php?this=this&amp;that=that">The Link</a>
Yes, your & needs to be &amp; amongst other things. Read the validators error results very carefully, as they will point you to all the problems. You're on the right track. If you can successfully validate your sites they will be easier to maintain in the future.

Last edited by Luxmo; 09-01-2010 at 05:21 PM.
 
Reply With Quote
  #3  
Old 09-02-2010, 02:48 PM
Rhyfelwr Rhyfelwr is offline
Contributing Member
 
Join Date: 08-21-10
Location: UK, Midlands
Posts: 79
iTrader: 0 / 0%
Cracked it - many thanks for your help.

I am now 100% valid!

Rhy
 
Reply With Quote
Go Back   Webmaster Forum > Web Development > Coding Forum

Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CSS/Html and PHP problem davidm23 Coding Forum 4 10-19-2009 09:19 PM
Inserting html page in other html page & shared border problem globalcashsite Web Design Lobby 5 07-16-2009 08:53 AM
can someone help me with a html problem on blogger jasonk1234 Blogging Forum 4 03-04-2008 06:34 AM
Small HTML <td> problem mrsam Coding Forum 5 04-18-2005 01:16 PM
Problem With HTML - I Think? www.Jq.s5.com Coding Forum 4 02-20-2004 08:12 AM


V7N Network
Get exposure! V7N I Love Photography V7N SEO Blog V7N Directory


All times are GMT -7. The time now is 05:59 PM.
Powered by vBulletin
Copyright 2000-2014 Jelsoft Enterprises Limited.
Copyright © 2003 - 2018 VIX-WomensForum LLC