Webmaster Forum

Go Back   Webmaster Forum > Web Development > Coding Forum

Coding Forum Problems with your code? Discuss coding issues, including JavaScript, PHP & MySQL, HTML & CSS, Flash & ActionScript, and more.


Reply
 
Thread Tools Display Modes
Share |
  #1  
Old 12-04-2016, 05:51 PM
HTMLBasicTutor's Avatar
HTMLBasicTutor HTMLBasicTutor is offline
Administrator
 
Join Date: 10-29-07
Location: Canada
Posts: 26,637
iTrader: 5 / 100%
Anchored Text on Mobile Devices

I have an anchored text for mobile users on a couple of my sites for them to jump to the navigation. I noticed on a friend's phone (think it was Samsung but definitely an Android) it doesn't work.

Any one know why and how to fix it?
 
Reply With Quote

Advertisement

Advertisement

  #2  
Old 01-08-2017, 02:45 PM
Roy1985's Avatar
Roy1985 Roy1985 is offline
Contributing Member
 
Join Date: 01-05-17
Posts: 53
iTrader: 0 / 0%
what is the site url?

i have a samsung phone i can try and check it out

what browser?
 
Reply With Quote
  #3  
Old 01-08-2017, 03:49 PM
Woomeister's Avatar
Woomeister Woomeister is offline
Contributing Member
 
Join Date: 11-10-16
Location: Gloucestershire
Posts: 1,262
iTrader: 0 / 0%
Quote:
Originally Posted by HTMLBasicTutor View Post
I have an anchored text for mobile users on a couple of my sites for them to jump to the navigation. I noticed on a friend's phone (think it was Samsung but definitely an Android) it doesn't work.

Any one know why and how to fix it?
I'm no coder but found this.

Try assigning an id to the element you're targeting (the one the page should scroll/jump to), and setting the link's href to that id, like this:

<a href="#second">Link</a>
<div id="first">
...
</div>
<div id="second">
...
</div>
 
Reply With Quote
  #4  
Old 01-14-2017, 06:56 PM
Woomeister's Avatar
Woomeister Woomeister is offline
Contributing Member
 
Join Date: 11-10-16
Location: Gloucestershire
Posts: 1,262
iTrader: 0 / 0%
So I'm guessing your lack of response means my post was of no use?
 
Reply With Quote
  #5  
Old 01-15-2017, 12:30 AM
HTMLBasicTutor's Avatar
HTMLBasicTutor HTMLBasicTutor is offline
Administrator
 
Join Date: 10-29-07
Location: Canada
Posts: 26,637
iTrader: 5 / 100%
Quote:
Originally Posted by Woomeister View Post
So I'm guessing your lack of response means my post was of no use?
No. I have been very busy!!!

I think my named anchor might be conflicting with the <nav> element now that I looked at it again. Haven't had a moment to test that theory out yet.
 
Reply With Quote
  #6  
Old 01-15-2017, 02:20 AM
Woomeister's Avatar
Woomeister Woomeister is offline
Contributing Member
 
Join Date: 11-10-16
Location: Gloucestershire
Posts: 1,262
iTrader: 0 / 0%
Quote:
Originally Posted by HTMLBasicTutor View Post
No. I have been very busy!!!

I think my named anchor might be conflicting with the <nav> element now that I looked at it again. Haven't had a moment to test that theory out yet.
I know that feeling! i hope you sort it out.
 
Reply With Quote
Go Back   Webmaster Forum > Web Development > Coding Forum

Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CSS media query for mobile devices Not Working andrewsegawa Coding Forum 3 07-09-2015 04:32 AM
Optimizing Forms for Mobile Devices HTMLBasicTutor Web Design Lobby 4 05-11-2015 02:52 AM
Google ads not showing on mobile devices? adsolist AdSense 9 07-18-2014 05:30 AM
Display Issues on mobile devices vcongion Coding Forum 0 07-24-2011 09:50 PM
SEO and Mobile Devices WM-Scott SEO Forum 9 08-31-2010 08:45 PM


V7N Network
Get exposure! V7N I Love Photography V7N SEO Blog V7N Directory


All times are GMT -7. The time now is 05:57 AM.
Powered by vBulletin
Copyright 2000-2014 Jelsoft Enterprises Limited.
Copyright © 2003 - 2018 VIX-WomensForum LLC