Webmaster Forum

Go Back   Webmaster Forum > Web Development > Coding Forum

Coding Forum Problems with your code? Discuss coding issues, including JavaScript, PHP & MySQL, HTML & CSS, Flash & ActionScript, and more.


Reply
 
Thread Tools Display Modes
Share |
  #1  
Old 03-11-2007, 10:33 PM
daniel0012's Avatar
daniel0012 daniel0012 is offline
Member
 
Join Date: 11-07-06
Location: Springfield
Posts: 111
iTrader: 0 / 0%
CSS code

For some reason my a:link code in CSS displays properly in firefox but not in IE7 or opera. Is there a difference in the browser I don't know about.
Code:
a:link { text-decoration: none; color: #AAAAAA; }
 
Reply With Quote

Advertisement

Advertisement

  #2  
Old 03-12-2007, 03:29 AM
Bagi Zoltán's Avatar
Bagi Zoltán Bagi Zoltán is offline
Contributing Member
 
Join Date: 11-28-06
Location: Hungary
Posts: 196
iTrader: 2 / 100%
If I were you I would remove the "link" and try only with this

a {text-decoration: none;
color: #AAAAAA;
}

It always works fine for me,
 
Reply With Quote
  #3  
Old 03-12-2007, 07:36 AM
daniel0012's Avatar
daniel0012 daniel0012 is offline
Member
 
Join Date: 11-07-06
Location: Springfield
Posts: 111
iTrader: 0 / 0%
I still have the same problem.
It looks great in one browser but the other two it doesn't. Is there a difference between them in how they read it?
 
Reply With Quote
  #4  
Old 03-12-2007, 11:12 AM
StupidScript's Avatar
StupidScript StupidScript is offline
Senior Member
 
Join Date: 09-22-06
Location: Los Angeles
Posts: 663
iTrader: 0 / 0%
Check out some of the code before that statement ... maybe missing a closing brace or something that's messing with the code further down the line. Try placing that instruction first in the instruction set.
 
Reply With Quote
  #5  
Old 03-12-2007, 11:15 AM
Taltos's Avatar
Taltos Taltos is offline
v7n Mentor
 
Join Date: 11-22-06
Location: Phoenix, AZ
Posts: 1,797
iTrader: 0 / 0%
No difference that I know of for just that little bit. There could be differences. Do you have the other psuedo classes for anchors? Like hover, visited, etc. There is a very specific order that they have to be in to work properly. They should be in order of :

link
visited
hover
active

Let us know.
 
Reply With Quote
Go Back   Webmaster Forum > Web Development > Coding Forum

Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BB code url markov Web Design Lobby 1 11-03-2006 08:13 PM
Google Code Search - Code Search Engine from the Big G Avinash Coding Forum 2 10-05-2006 10:10 PM
Help need for php code GoWFB_SEO Coding Forum 12 07-07-2006 02:28 PM
need help with a code kopythat Coding Forum 10 03-11-2004 06:31 PM


V7N Network
Get exposure! V7N I Love Photography V7N SEO Blog V7N Directory


All times are GMT -7. The time now is 06:38 PM.
Powered by vBulletin
Copyright © 2000-2014 Jelsoft Enterprises Limited.
Copyright © 2003 - 2018 VIX-WomensForum LLC