Webmaster Forum

Go Back   Webmaster Forum > Web Development > Coding Forum

Coding Forum Problems with your code? Discuss coding issues, including JavaScript, PHP & MySQL, HTML & CSS, Flash & ActionScript, and more.


Closed Thread
 
Thread Tools Display Modes
Share |
  #1  
Old 04-02-2018, 01:39 PM
SunEmbroidery's Avatar
SunEmbroidery SunEmbroidery is offline
Contributing Member
 
Join Date: 04-11-08
Location: Seaville, NJ
Posts: 85
iTrader: 0 / 0%
Problem Moving Inline Style To Existing CSS File

I'm unable to move an inline style for my logo header on an html page to an existing css file. This is the original html:

HTML Code:
<div id="logo"> <span class= "greentext"> <a href="http://www.v7n.com/forums/index.htm" title="Text - Home"> <img alt="Atext Btext Ctext Dtext - Home" src="http://www.v7n.com/forums/javascripts/images/catalog/logo-text.png" style="margin-bottom: -0.9%"></a><br>Atext</span><span class= "bluetext"> Btext</span> <p class= "whitetext">Ctext</p> <p class= "bluetextsm">Dtext </p> </div>
I added a class to the css:
.imgmargin {margin-bottom: -0.9%}

and replaced the inline style with class="imgmargin" to the html.

What am I doing wrong? Thanks!
 

Advertisement

Advertisement

  #2  
Old 04-04-2018, 02:13 PM
wmtips's Avatar
wmtips wmtips is offline
Junior Member
 
Join Date: 01-14-08
Posts: 9
iTrader: 0 / 0%
Maybe your browser haven't updated earlier cached CSS file, try to press Ctrl+F5 or clean your browser cache
 
  #3  
Old 04-04-2018, 09:59 PM
JackMiller7 JackMiller7 is offline
Contributing Member
 
Join Date: 03-22-18
Posts: 251
iTrader: 0 / 0%
I don't see a problem with what you wrote here, can you post the site so I can use inspect tool to see why the css class may not be calling/functioning
 
  #4  
Old 04-05-2018, 05:22 PM
SunEmbroidery's Avatar
SunEmbroidery SunEmbroidery is offline
Contributing Member
 
Join Date: 04-11-08
Location: Seaville, NJ
Posts: 85
iTrader: 0 / 0%
I didn't publish the change (I only previewed in a browser) because when I tried the change my green text - "AText" (first word in my business name) turned black and its viewed against a black header so I didn't want every page of my site look that way and I don't want to be penalized for having black text against a black background (hidden text). If you want to visualize the header the site is https://www.sunembroideryscreenprintingdotcom.
 
  #5  
Old 04-20-2018, 07:53 AM
SunEmbroidery's Avatar
SunEmbroidery SunEmbroidery is offline
Contributing Member
 
Join Date: 04-11-08
Location: Seaville, NJ
Posts: 85
iTrader: 0 / 0%
I managed to fix this. I don't know why it didn't work the first time. Creating the style in the CSS file and replacing the inline style with that class applied to the image fixed the problem.
 
Go Back   Webmaster Forum > Web Development > Coding Forum

Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


V7N Network
Get exposure! V7N I Love Photography V7N SEO Blog V7N Directory


All times are GMT -7. The time now is 07:06 PM.
Powered by vBulletin
Copyright 2000-2014 Jelsoft Enterprises Limited.
Copyright © 2003 - 2018 VIX-WomensForum LLC